Sphinx works fine, but can't start a new simulation without rebooting since the virtual eth0 device is still active and the wifi device no longer shows up (via ifconfig)

#1

Hi,
Parrot Sphinx works fine for me, Camera view of the virtual world and everything works great.
I only have one problem. After ending a simulation I can not start a new one without a reboot.
Apparently the virtual device eth0 does not stop, and the wifi device no longer shows up with iwconfig.
I’ve tried fdc KILL_ALL, fdc drop_all instances… Does not work. Is there a method of dropping the virtual eth0 device ?

Also tomorrow I’m launching my Disco on a FlightPlan mission from my club’s airfield.
I’ve got a linear landing programmed.

Have you looked at implementing GazeboRosGps in parrot-sphinx ?

#2

https://developer.parrot.com/docs/sphinx/troubleshooting.html#my-wifi-interface-got-its-name-changed-after-exiting-the-simulation
Have you tried doing this?

No, we have not looked into that. Sphinx has its own GPS plugin to send NMEA frames to the firmware.

#3

The wifi device name is getting changed. When I exit the simulation no wifi device shows up. The virtual eth0 device is still up. That’s why I tried to clean things up with fdc

Is there a document showing how to use the Parrot Sphinx GPS plugin ?

Also my maiden flight of my.replacment Disco was GREAT!

Here is the link to the video

Next flight is Saturday! The weekend can’t come soon enough!