Streaming example no image is showing

I followed the user-guide steps by steps to test the streaming example at Sphinx environment, but I got the following error

Traceback (most recent call last):
File "ctypes/callbacks.c", line 234, in ‘calling callback function’
File “/home/tara/Documents/parrot-groundsdk/out/olympe-linux/final/usr/lib/python/site-packages/olympe_deps.py”, line 81, in
type
((lambda callback: lambda *args: callback(*args))(
File “/home/tara/Documents/parrot-groundsdk/packages/olympe/src/olympe/arsdkng/pdraw.py”, line 840, in _media_added
if (media_info.contents._2.video.format !=
AttributeError: ‘struct_pdraw_media_info’ object has no attribute ‘_2’

As expected, there should be a new window continuously showing the FPV image from the drone. However, the window only showed black in my case.

My goal is to post-processing the FPV image, but the function show_yuv_frame seems not to be called at all. So how can I get access to the current frame? How can I fix the problem to make it work as expected in the example?

Thanks in advance

1 Like

I’m having the same issue, I think it’s a problem with the current version of PDrAW. I posted it on this forum: Streaming video errors on Raspberry Pi - #18 by wapy1234

Hopefully one of the admins will help out :slight_smile:

I’m also having exactly the same issue. Have you solved it?

I have the same, someone solved ?

We would need the exact distribution version of Linux and libraries installed.
Thanks

2 Likes

@Jerome

  1. linux version:
    Linux version 5.4.0-67-generic (buildd@lcy01-amd64-010) (gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04)) #75~18.04.1-Ubuntu SMP Tue Feb 23 19:17:50 UTC 2021
  2. libraries installed:
    https://1drv.ms/t/s!AttmLZY02zHrhJsj1uZ8xVMKIMmjFg?e=p1y3eZ

I found one solution to this problem. If you type rtsp://192.168.42.1/live in your browser while you´re connected to Anafi via WiFi, VLC will open you the streaming. Image quality and latency are poor, but we have something with this.

Hope Parrot devs are looking for a better solution

Dani

1 Like