is giving error

I am trying to run the example, but it is giving an error
The platform is RaspberryPi 4 ubuntu 22.04, python 3.9.5 and pip 21.1.1; also this is with the physical drone using Olympe 7.2 and 7.1 connected via remote controller.

Traceback (most recent call last):
  File "/home/dtadmin/code/parrot-groundsdk/src/olympe/doc/examples/", line 21, in <module>
    from import PdrawRenderer
  File "/home/dtadmin/code/parrot-groundsdk/out/olympe-linux/staging/usr/lib/python/site-packages/olympe/video/", line 8, in <module>
    from OpenGL import GLX
  File "/home/dtadmin/code/parrot-groundsdk/out/olympe-linux/staging/usr/lib/python/site-packages/OpenGL/GLX/", line 3, in <module>
    from OpenGL.GLX.VERSION.GLX_1_0 import *
  File "/home/dtadmin/code/parrot-groundsdk/out/olympe-linux/staging/usr/lib/python/site-packages/OpenGL/GLX/VERSION/", line 14, in <module>
    from OpenGL.raw.GLX.VERSION.GLX_1_0 import *
  File "/home/dtadmin/code/parrot-groundsdk/out/olympe-linux/staging/usr/lib/python/site-packages/OpenGL/raw/GLX/VERSION/", line 44, in <module>
    def glXChooseVisual(dpy,screen,attribList):pass
  File "/home/dtadmin/code/parrot-groundsdk/out/olympe-linux/staging/usr/lib/python/site-packages/OpenGL/raw/GLX/VERSION/", line 13, in _f
    return _p.createFunction( function,_p.PLATFORM.GLX,'GLX_VERSION_GLX_1_0',error_checker=_errors._error_checker)
AttributeError: 'EGLPlatform' object has no attribute 'GLX'

I would highly appreciate some help.
Thank you in advance!
Best regards.

Hello All,

Somehow I am not able to edit my post, so adding more info as a reply.

Additional information is works when I connect to the RaspberryPi using the remote desktop connection from my Windows 10 machine, but on RaspberryPi directly it gives the same error.
Also, I had to comment following four lines 55-58 otherwise it gives an error that the encoder is not found

    video=os.path.join(self.tempd, "streaming.mp4"),
    metadata=os.path.join(self.tempd, "streaming_metadata.json"),

Overall it is strange, I am looking on other PI forums related to OpenGL but have had no success so far.

Also would like to know if anyone had gotten it working from a RaspberryPi in past.
I would highly appreciate any help or pointers on this.

Best regards

Hi Satya,

I ran into the same issue, and it seems that olympe does not support ubuntu 22.04
It seems to work just fine with ubuntu 20.04

Hello Marcus,

Thank you as you said It does work on ubuntu 20.04.

Best regards

This topic was automatically closed after 30 days. New replies are no longer allowed.