Streaming Video

I am trying to use olympe to connect to a Sphinx anafi 4k simulation and stream video.

Some example code might be:

import olympe
drone = olympe.Drone("")

When doing this I will get the following error:

2020-12-03 01:46:23,715 [ERROR]         olympe.drone. - start_video_streaming - Unable to enable legacy video streaming

I do seem to get these messages regarding discovery on connection:

2020-12-03 01:46:23,049 [INFO]  olympe.drone - connect - Net discovery failed for b''
2020-12-03 01:46:23,049 [INFO]  olympe.drone - connect - Trying 'NetRaw' discovery for b'' ...
2020-12-03 01:46:23,056 [INFO]  olympe.backend - _device_added_cb - New device has been detected: ''

I am not connected to Sphinx via the wifi hotspot, I’m using olympe either on another machine going through another LAN interface on the Sphinx box, or running olympe locally on the same box as Sphinx.

It looks like it is going to legacy mode because discovery results in a device type of -1.

I tried setting drone_type when instantiating olympe.Drone, but looking through the code it looks like that variable doesn’t actually do any thing.

I also tried hardcoding legacy=False in the pdraw init call in and that also does not appear to work. Looking at the sphinx box I don’t see anything listening on RTSP port 554.