Time Synchronization issues with Sphinx/Olympe


I am trying to use Sphinx on an AWS but I am getting the following error when trying to connect to the drone:

olympe.drone.ANAFI Ai 000000 - _on_sync_done - Time synchronization failed for b’’

Does someone has any idea what the issue could be by any chance?

The setup is the following:
EC2 instance on AWS running Sphinx and OpenVPN
PC running Olympe connects to the drone via the OpenVPN server and port-forwarding using socat.

I think the port-forwarding is working since:

  • I can access the web interface of the drone from the PC running Olympe through the VPN and socat.
  • I can run a simple Python script with Olympe on the AWS instance itself but going through socat.

Is there any chance this issue could be because of latency?

Here are the ports I’m forwarding (from another thread I had opened, thank you, ndessart):

drone port:
tcp/44445 (arsdk net discovery)
tcp/44444 (arsdk net control)
udp/2233 (arsdk net command)
tcp/80 (optionally: the drone web API used by Olympe to list / download media resources)

olympe ports:
udp/9988 (arsdk net command)

Another detail: both the PC and EC2 instance are in the same geographical region, with pings around 50ms

Thank you very much!


Have you tried the “remote_ctrl_ip” machine parameter? It tells firmwared to perform port forwarding via iptables.
You can see exactly what it does in /opt/parrot-sphinx/usr/libexec/firmwared/net.hook

1 Like


I don’t know how I never saw that parameter after hours trying, thank you so much, everything is working now!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.