Unable to build any mission

I can’t build any mission on my computer when creating it with airsdk-cli.
I create the mission with airsdk init. Then I try to build it with airsdk build --simulator but it fails with the following error.
Note that I am under ubuntu 22.04.
Traceback (most recent call last): File "/opt/parrot-airsdk/parrot-airsdk-base/build/dragon_buildext_sign/sign.py", line 378, in <module> main() File "/opt/parrot-airsdk/parrot-airsdk-base/build/dragon_buildext_sign/sign.py", line 374, in main sign_archive(options.archive, options.name, filenames, provider, hash_func, purpose=options.purpose) File "/opt/parrot-airsdk/parrot-airsdk-base/build/dragon_buildext_sign/sign.py", line 313, in sign_archive add_signature_file(archive, name, signature_contents) File "/opt/parrot-airsdk/parrot-airsdk-base/build/dragon_buildext_sign/sign.py", line 288, in add_signature_file tarfd.add(tmpfd.name, name) File "/usr/lib/python3.10/tarfile.py", line 2002, in add self.addfile(tarinfo, f) File "/usr/lib/python3.10/tarfile.py", line 2024, in addfile buf = tarinfo.tobuf(self.format, self.encoding, self.errors) File "/usr/lib/python3.10/tarfile.py", line 825, in tobuf return self.create_ustar_header(info, encoding, errors) File "/usr/lib/python3.10/tarfile.py", line 844, in create_ustar_header return self._create_header(info, USTAR_FORMAT, encoding, errors) File "/usr/lib/python3.10/tarfile.py", line 956, in _create_header itn(info.get("uid", 0), 8, format), File "/usr/lib/python3.10/tarfile.py", line 218, in itn raise ValueError("overflow in number field") ValueError: overflow in number field [E] Command failed (returncode=1)

I finally found a solution. This problem occurred when I tried to compile a project with parrot-airsdk-cli for the first time and my version of the package was the 7.5.3.
First I downgraded my version to the 7.5.0 with the command sudo apt reinstall parrot-airsdk-cli=0:7.5.0-release. Then to avoid an error I modified the file /opt/parrot-airsdk/parrot-airsdk-base/build/dragon_buildext_sign/sign.py an replaced tarfile.open(tfn, 'w:gz', format=tarfile.USTAR_FORMAT) by tarfile.open(tfn, 'w:gz', format=tarfile.GNU_FORMAT).
Then it worked well.
To give more details, the first time we compile, a file needs to be downloaded and uncompressed. In the last version (7.5.3) it seems this stage doesn’t work. One this file has been downloaded, then you can reinstall the latest version with sudo apt reinstall parrot-airsdk-cli. If you don’t do this you may encounter other problems when installing the mission with airsdk install --simulator.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.