Unable to discover the device: b''

I have installed everrything as directed, and after launching the simulation and a world of choice, I have my drone ready.

When I run the basic take off test however, the drone cannot connect to

When i ping the IP I do get a response.

Tried a variety of suggestions : set name of Wifi, reinstalled the software, tried manually setting wifi iface parameter but to no avail.

What is interesting is that the very first time i did it, it worked and I was able to see the simulation run. The next time i tried a day later it does not connect. Other similar threads on this have not been answered - any suggestions to help me out?

Further, on closing the simulator the process does not exist and I have to reboot the computer to actually exit the simulation and free the wifi card. fdc drop all instances and just normal ctrl-c do not work


Can you tell us what your Linux distribution and your kernel version (with uname -r) are? Sphinx is not yet compatible with kernel >= 6.2.

Can you provide us sphinx and ulog logs with extra logs from firmwared?

I’m having the same problem after upgrade to Ubuntu 22.04. After switch to kernel 5.15, everthing works again.

Yes, my kernel is 6.2.0-generic

Because it worked the first time I was wondering what happened. Will try to roll back the kernels and get it working. Thank you!

This topic was automatically closed after 30 days. New replies are no longer allowed.