Unable to import olympe python library

I am trying to write scripts using “olympe”, so I followed the installation guide, but then a simple

import olympe

is giving me a lot of errors, such as :

File "/home/lilian/code/parrot-groundsdk/.python/py3/lib/python3.6/site-packages/aenum/__init__.py", line 2724, in _create_
    enum_class = metacls.__new__(metacls, class_name, bases, clsdict, boundary=boundary)
TypeError: __new__() got an unexpected keyword argument 'boundary'
File "/home/lilian/code/parrot-groundsdk/packages/olympe/src/olympe/arsdkng/module_loader.py", line 83, in find_spec
    if not fullname.startswith(self.message_root) and not fullname.startswith(self.enum_root):
AttributeError: 'ModuleLoader' object has no attribute 'message_root'
File "/home/lilian/code/parrot-groundsdk/packages/olympe/src/olympe/arsdkng/drone.py", line 70, in <module>
    from olympe.messages import ardrone3
ModuleNotFoundError: No module named 'olympe.messages'

I have tried the manual installation, to pip install -r requirements.txt, and tried everything advised in other thread but nothing seems to work.

I am using a VM with Ubuntu 18.04 (bionic), and I have python 2.7.17, python 3.6.9.

Does anyone have a solution ?

Hello, Lilian

It is similar to the following page.

I hope the problem will be solved.

docker pull docker.io/djohnsonara/olympe then run the container. Fixed!