Import olympe olympe.messages not found

When I try to test the olympe installation with
python -c 'import olympe; print(“Installation OK”)'

I get errors leading to
ModuleNotFoundError: No module named 'olympe.messages’

The install and alchemy script seemed to run without any problems. What am I missing?

3 Likes

Could someone please help me with this? I’ve been trying to get olympe installed for days now without any luck. Could someone direct me to how or where this olympe.messages module should be installed or created?
Thx

1 Like

I have the same problem. I made a fresh ubuntu installation and use manual installation with no error. But when i try the installation, I have the same error.

1 Like

I am facing the same issue. I installed Olympe on a fresh copy of Ubuntu 18.04. I did not face any error while installing Olympe. However when I try to test the installation, I get the error “ModuleNotFoundError: No module named 'olympe.messages”.

@pwdrone Were you able to fix this error?

Still working on it. This is what I did next:

  1. fresh ubuntu 18.04.5 LTS install (dual boot) and followed every step in this guide:
    Parrot Olympe Ubuntu 18.04 setup from zero - YouTube
  2. install virtualbox on another windows machine and run ubuntu 18.04.5 LTS in virtual box. Followed every step according to this guide:
    Parrot Olympe Installation Tutorial - YouTube

Both methods still give me the same error. I’m starting to wonder if all necessary files are still in the git. Looks like modules like olympe, olympe.messages and media are just missing.

Is there anyone able to do a succesful install with the current git?

Edit: also, during postinst I get 3 warnings ignoring faulthandler, futures and textwrap3. Do they have something to do with olympe.messages?

@Jerome We need your help to resolve this issue.

I’ve been digging through the scripts and I think I am missing some files/folders like Messages, Enums and Media. This is how my final folder looks like.

Can anyone with a working Olympe check their final folder and verify if I’m missing something?
Thx

I’m having the same issue. Does anyone have an update on this one?

I have also run into this problem and I think it is a problem with the aenum Python package that Olympe is using. For me it worked fine if I downgraded to an older version of aenum.

Start the Olympe virtual environment and type:
pip install --upgrade aenum==2.2.5

4 Likes

Thank you so much !!!

Like you suggested I entered the olympe environment:

source ~/code/parrot-groundsdk/./products/olympe/linux/env/shell

and then downgraded the aenum:

pip install --upgrade aenum==2.2.5

When I did the import olympe test I finally got the “Installation OK” !

You’re a lifesaver sir !

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.