Upload mission failed

I am facing a problem during uploading the mission,
the error says- Upload failed: Invalid Mission SDK version.

Hi @abdullah7,

Can you give me the version of your airsdk-cli and your drone ?

For airsdk-cli (give me all the ouput please):

$ airsdk --version

For the drone, you can found the version on FreeFlight app or in the webserver.


Hi @Axelm

Anafi Ai Firmware : 7.7.1
Vehicle Mission: 7.7.0

Let me know if you need anything else

Hi @abdullah7, thank you.

I notice that your airsdk classic version and airsdk pc versions (last screenshot) are not up-to-date. You can update your SDK (classic and pc in the same time) with this command:

$ apt update
$ apt-get --only-upgrade install parrot-airsdk-base 

after that, retry this command :

$ airsdk --version

you should get this.

Before rebuild and install your mission, clean your mission build with this command (in your mission directory)

$ airsdk clean


Tried doing it, sill not happening.

Can you give me your linux distribution please ?

Anything which i can do?

Hi @abdullah7,

We’ve checked our side and everything looks good. The package is available for your version of Ubuntu. We are still analysing your problem. I think you’ve tried apt update and apt-get --only-upgrade install parrot-airsdk-base again in the meantime and it still didn’t work?

Have you tried installing it on another computer just to check that it didn’t come from your computer?

Sorry for all the questions, we’re trying to find a solution to your problem.


It worked on a different computer.

This topic was automatically closed after 30 days. New replies are no longer allowed.