Using CameraMan Mission using Sphinx


I’m trying to test tracking algorithm with Anafi AI in the Sphinx Simulator.
When I connect FreeFlight7 to the emulated AnafiAI, the only missions I see are “Piloting, Photogrammetry, Flight Plan, Cameraman and Touch & Fly”. I can’t see Vehicle neither Follow Me to test tracking.
When I try Cameraman and I select Jasper with the blue rectangle, nothing happen.

Any ideas ?


Visual tracking is not officially available on sphinx: Shortcomings and limitations - 2.6

You can simulate a deteriorated version of the visual tracking feature by running this pair of commands while a simulation is running:

adb connect anafi-ai.local:9050
adb shell pstart selkie

Hi @ocrave,
I tried to run your commands :

adb connect anafi-ai.local:9050

But it seems that anafi-ai.local:9050 isn’t known.

* daemon not running; starting now at tcp:5037
* daemon started successfully
unable to connect to anafi-ai.local:9050: Name or service not known

Is there anything to do to connec to anafi-ai.local ?


You need to run this command when the simulated drone is running. What about this command?

adb connect

Can you ping anafi-ai.local?

Alright using IP adress instead of hostname it works, I can connect to it and run adb shell pstart selkie.
But nothing changes on Cameraman mission …

Do you have an actor in your scene? How do you start your unreal app?

Yes you can see Japser in the first screenshot. I run the parrot-ue4-empty with Jasper like this :

sphinx "/opt/parrot-sphinx/usr/share/sphinx/drones/anafi_ai.drone"::firmware="" && 
parrot-ue4-empty -ams-path=RunPath,Jasper:*

That seems OK. What firmware version are you running?

When I run Sphinx, it says

Parrot-Sphinx simulator version 2.6

Connecting to firmwared version: 2.6
starting Telemetryd to capture true data...
Gazebo multi-robot simulator, version 11.2.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.

In FreeFlight7, it says AnafiAI firmware is 7.1.0

Here is a quick video showing that I can’t select Jasper as target : MAGcloud

I have not tried with sphinx 2.6, but I was able to make it work with sphinx 2.7. Can you try with that version? You need to update sphinx and parrot-ue4-empty.

Perfect, It works with Sphinx 2.7.

Thank you for your help !


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.