Virtual drone connection problems, can't run simple "takeoff.py" script

I was following Installation procedure - 2.10.3 and Installation - 7.4 documentation and everything looked fine:



till trying to run test python code “takeoff.py” , got this problem

do you know whats the problem?

Hello
I also have the same problem. I wanted to write a topic, but I can complete yours.



I launched the commands in the following order

  1. Start of firmwared service
  2. Run parrot-ue4-empty
  3. Run sphinx (i have tried several configuration without success)
  4. And the Olympe script

the configurations of my computer:

  • Ubuntu 22.04.1 LTS
  • dell XPS 15 9520
  • CPU intel core i7-12700H
  • NVDIA RTX 3050 TI with the last nvdia driver (nvidia-525
  • 16 Go RAM

I don’t know which version of Olympe you have installed but, Olympe 7.4.2 (the latest stable release of Olympe) is not compatible with Python 3.10 that comes with Ubuntu 22.04. You should not even be able to simply “import olympe” with Python 3.10.

Olympe 7.5.0-rc1 (pre-release available on pypi.org) is compatible with Ubuntu 22.04 and Python 3.10.

Can you please install Olympe 7.5.0-rc1 on your machine ?
You should first uninstall the “protobuf” and “parrot-olympe” Python package because Olympe 7.4.X used to bundle protobuf which was an infinite source of random dependency issues. Olympe 7.5.X no longer bundles protobuf.

pip uninstall protobuf
pip uninstall parrot-olympe
pip install --user --pre parrot-olympe # install the latest pre-release

If possible, could you please test connecting Olympe to a physical drone ?
Which version of Sphinx are you using ?

i have venv with python 3.9.5 version, olympe 7.4.2 version, sphinx 2.10.3 version :

After
pip uninstall protobuf
pip uninstall parrot-olympe
pip install --user --pre parrot-olympe

error
File “/home/droneteam/takeoff.py”, line 1, in
import olympe

can’t even import olympe

Hello, Thank you for your answer.

I already use a python venv in 3.9.16. I can connect it to a real drone but not to sphinx.

I have done the commands you give in your answer but unfortunately it has no effect, I still get the same connection error .


I use a sphinx in 2.10.3.

Problem solved by doing everything on ubuntu 20.04 !!!

Hello,

After updating the simulator and Olympe for the latest version, it finally works on Ubuntu 22.04.

Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.