Which opencv python version for olympe streaming example?

Hey there,
I was trying to get the streaming example to work, unfortunately I received an error that import cv2 was not working.
So I installed opencv with

pip install opencv-python in the virtual environment

…which installed version
running the example created a segmentation fault, therefore I uninstalled opencv-python and installed an older 3.1.x version, which looked better.
This however creates the following error:

OpenCV Error: Unspecified error (The function is not implemented. Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, then re-run cmake or configure script) in cvShowImage, file /io/opencv/modules/highgui/src/window.cpp, line 605
Traceback (most recent call last):
File “_ctypes/callbacks.c”, line 234, in ‘calling callback function’

So my question is, which version of opencv-python should be used to get the video-streaming running?


I’ve just upgraded opencv-python in my environment to the release and everything still works perfectly fine for me on Ubuntu 18.04.

You must have a system dependency issue on your system. What is your linux distribution release? Could you please re-run the ./product/olympe/linux/env/postinst script and post its output here?



Hi Nicholas,
thanks for taking the time.
I’m using a kubuntu 18.04.04 LTS. Here’s the output of uname -a:
Linux marcel-HP-Spectre 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Unfortunately, I cannot share the output of the postinst file, as it contains multiple links from the apt-get update which new users are not allowed to post. I tried to upload the logfile, but this is also not allowed :frowning:

Link to Log-File on Google-Drive

apart from others, It seems that there are dependencies to sphinx 2.3.1 which cannot be resolved by the pip version installed through get-pip.py …

Hi hellowtisch

This issue has been fixed in the 1.2.0 release that has just been released today.
You should repo sync again and follow the installation procedure from there.


Hi Nicolas,

while trying to install 1.2.0 I received the following error:
Successfully built sphinx-prompt pycrypto py-lz4framed PyYAML
ERROR: sphinx-substitution-extensions 2018.11.12.3 has requirement sphinx==1.8.2, but you’ll have sphinx 1.8.5 which is incompatible.


I’ve noticed that error message too but this should have no further consequence, right? Olympe should be working fine even with this error message.