Unable to change wlo1 to wlan0

Hello to everyone, i’m a newbie, i’m trying to figure it out why sphinx doesn’t work, precisely:
when i press iwconfig as output i got wlo1 as my interface name, but in the tutorial First step — Parrot-Sphinx 1.2.1 documentation i have to write on command line

  • sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/anafi4k.drone::stolen_interface = <“wlo1”>:eth0:192.168.42.1/24

i tried to not put even “” but will be as output:
bash: wlo1: File o directory not exists

can you please help me to undertand and resolve the problem?
Thanks :slight_smile:

Have you tried the following? There should be no space between stolen_interface and the equal sign.

sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/anafi4k.drone::stolen_interface="wlo1:eth0:192.168.42.1/24"

You can also create a new udev rule to rename your wireless interface into wlan0: Troubleshooting — Parrot-Sphinx 1.2.1 documentation

[Err] [Machine.cc:1077] Failed to start anafi4k : net.hook/assign failed.
[Err] [Machine.cc:1084] Probable cause for this error: the requested stolen interface (wlo1:eth0:192.168.42.1/24) does not exist

the simulation started with a drone, but will immediatly shut down with this error

If you don’t need a wireless interface, you can just pass an empty ::stolen_interface= in your command line.

Are you sure that wlo1 exists and is a valid wireless interface and that your wireless device is supported? Check the documentation here: System requirements — Parrot-Sphinx 1.2.1 documentation

$iw list | grep -A20 “Supported interface modes”
Supported interface modes:
* IBSS
* managed
* AP
Band 1:
Capabilities: 0x1962
HT20/HT40
Static SM Power Save
RX HT20 SGI
RX HT40 SGI
RX STBC 1-stream
Max AMSDU length: 7935 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 16 usec (0x07)
HT Max RX data rate: 150 Mbps
HT TX/RX MCS rate indexes supported: 0-7
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps
* 5.5 Mbps
$lspci -nnk | grep -A2 0280
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
Subsystem: Hewlett-Packard Company RTL8821CE 802.11ac PCIe Wireless Network Adapter [103c:831a]
Kernel driver in use: rtl8821ce

in the docs is written RTL8192CU based known to have problem, i don’t know if mine is based on this, do you suggest to buy a wifi adapter?

$ sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/anafi4k.drone::stolen_interface=""

i pressed this command and it worked all fine, thanks for the support i appreciate it :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.