Video streaming shows black window

I’m trying to get the streaming working for Anafi AI using olympe. I can not get any video feedback from the simulated drone. I have tried to run the from the examples. The program runs and the video stream window opens but the screen is fully black.

My final goal is to do some real time image recognition using cv2 and managed to make some test code for it but the same problem occurs. The program launches a streaming window which shows only empty black window. I suspect that something is preventing the video feed to be shown.

Does anyone know how I could fix this problem?

same problem

A bit more information on the problem as I’m still struggling with it. In the found in the documentation the “yuv_frame” on line 97 seems to be empty. Because of this the streaming window is also empty. I have tried to increase the timeout limit if my computer is just slow but this has not helped.

I seem to have the exact same problem as @DovydasPocius in this post.

This is fairly new to me so there might be something trivial that I’m missing out. Any help would be appreciated.

This topic was automatically closed after 30 days. New replies are no longer allowed.