Sphinx - Unable to fly after reset


I want to be able to reset my Sphinx simulation without restarting the entire program as this takes time due to some large models. The reset in itself works well in Sphinx, but after one reset I cannot take off again, getting takeoff unsuccessful if I try e.g. the takeoff.py example. This happens every time I try it again, and the only way I have found to solve the problem is to restart Sphinx.

I have tried using the Gazebo shortcut Ctrl-R to reset the whole world, Ctrl-Shift-R to reset the model pose and the Python method used in this post (which I think is just the same as Ctrl-R in Sphinx).

Anybody have any ideas? All help is greatly appreciated!

So I had another problem with the world I was using as well which was that I had forgotten to update the magnetic field when I updated the GPS position (see this post for how to do that and remember that the format for Sphinx is East-North-Up, so you need to flip the sign of the vertical component from the calculator).

Anyways, after I fixed that the issue with the resetting went away. I do not know why this fixed it or if this was the mistake at all, but I am posting it here to close the thread.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.